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Getting Started with RMS 1
 

RMS Data Forms 
RMS data is displayed in a variety of forms. Each form opens in its 
own window. 
There are forms for searching, data entry, data display, and 
scheduling events. Many forms combine more than one of these 
functions. 
Forms are stored in a hierarchical folder structure organized by 
function and/or type of information. 
The primary access to forms is through the Retek Start window, 
which functions like the Windows Explorer file window. (See section 
2.) 

How do I log in to RMS? 
1. From Internet Explorer, in the address field, type the URL below 

and press Enter. 
 http://rms-production.gap.com 

2.  In the Log in window, enter 
your username and password. 
Click OK. 

3. The application opens with 
the Start window displayed. 

 

 

The RMS Application Layout 
The RMS Web-based application has a menu bar at the top 
and a “desktop” area beneath to display the data form 
windows. 

The RMS Application Menu Bar 
The RMS menu bar is context sensitive. Certain menu 
options change depending on which form is active. 

 

Menu Function 
Action Provides the application Close option. 

Edit In addition to the standard Cut, Copy, 
Paste options, Edit opens a text editing 
window for text fields. List opens a 
LOV dialog. 

Options Changes with each form, providing the 
opportunity to enter additional 
information. 

View Provides display options for forms with 
multi-view tables. 

Help Lists the online help options. 

Window Lists open windows so you can easily 
switch between them.  

 

 

 

Application Menu Bar Desktop for form windows 

Check this table of 
contents for the task 

P
F
I 

you need –  
then go to that section 

for the steps 
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2 Opening Forms Using the Start Window 
 

How do I search for specific folders or forms? 

 
1. In the Search field, type part of the name you are searching for. 
2. Click the left-hand search button to search forward (toward the 

bottom of the file hierarchy) from the currently selected 
folder. 

 OR 
 Click the right hand button to search backward from the 

currently selected folder. 
 Both folders and forms containing the search text will be 

highlighted. If necessary, the folder hierarchy is automatically 
expanded to display the search target. 

3. Repeat as necessary to locate the folder or form. 

The Retek Enterprise Start Window 
The Start window provides immediate access to all forms. It 
is the only window displayed when RMS is started. 
Depending on the permissions associated with your user 
access, you will see some or all of the available folders and 
forms. 

 
How do I open a form? 

1. Double click the associated form icon.  
Typically, this opens a search form for the selected function. 
If the icon is named New, View or Edit, then a form opens at the 
selected access level. 

How do I navigate through the folders? 
The Retek Start window uses the same conventions as the 
Windows Explorer window. 
Folders may contain other folders or forms. Only folders 
appear in the folder list pane. Both folders and forms can 
appear in the contents pane. 

To: Do this: 
Open a folder In the left pane, click the closed 

folder icon. In the right pane, 
double-click the closed folder icon. 

Open a folder and 
its immediate 
subfolders 

Double click the closed folder 
icon. 

Close the 
hierarchy of 
subfolders below a 
folder 

Double click the open folder icon. 
Note: This is referred to as 
“collapsing the hierarchy.” 

 

 
The Folder Controls 
Control Function 

 
Expands the currently selected folder to display 
all subfolders. 

 Collapses the currently selected folder. 

 
Adds a user-created folder to the end of the 
hierarchy. 

 Deletes the selected user folder. 

The Form Controls 
Control Function 

 Opens the selected form. 

 Adds URL of external application to user 
folder. 

 Removes URL from selected user folder. 

 Creates form shortcut on Menu Bar. 
 

Tool Bar 

Folder 
list pane 

Folder 
contents 
pane 

Folder 
controls 

Form 
controls 

Folder /form 
search controls 
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Customizing RMS 3 

You can customize RMS in three ways: 
1. Add folders to the Start window with links to other 

Web based applications such as Crystal Reports and 
GapWeb. 

2. Add buttons to the toolbar to directly launch 
selected forms. 

3. Create custom views of forms tables to display 
selected data. 

 

How do I add an “open form” button to the 
toolbar? 
1. Use the navigation controls to display the form in 

the Contents pane. 
2. Select the form. 

3. Click Add favorite . 
4. In the Add a Toolbar Favorite window, select a button 

image by clicking it. 

How do I manage the buttons I create on the 
toolbar? 
1. From the Options menu, select Edit toolbar. 
2. In the Edit Toolbar Favorites window, you have the 

following options:  

To: Do this: 
Delete a 
button 

1. Select the icon. 
2. Click Remove. 

Rename 
the Tool 
Tip 

1. Select the icon. 
2. Click Rename. 
3. Type the new name. Click OK. 

Add a 
space 
between 
buttons 

1. Select the icon you want the space 
to be to the left of. 

2. Click Space. 

3. When finished making changes, click OK. 

 

How do I add a “user folder” to the Start window? 
1. At the bottom left of the Start window, click Add user 

folder . 
2. In the Folder Name field, type a name, click OK. 

How do I remove a “user folder”? 
1. Select the folder. 
2. At the bottom left of the Start window, click Remove 

user folder . 

How do I add a link to other applications in my 
folders? 
1. Open the folder by clicking it. 

2. Click Add user element . 
3. In the Add User Element window, type the complete URL 

of the application starting with “http://…”, a name, 
click OK. 

How do I remove a link to an application from a 
user folder? 
1. Open the folder by clicking it. 
2. In the Contents pane, select the element. 

3. Click Remove user element . 
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3 Customizing RMS … continued 

Custom tables available in some forms 
The tables in certain forms are “multi-view”. Multi-view 
tables can be customized in a variety of ways. The custom 
view is only available while the form is open, but it can be 
saved for future use. 
There is only one saved view per form for each user. You 
can’t share your saved view with another user. 

L Tip: The View menu only displays if the 

currently active window contains a multi-view table. 
 

How do I select a view? 
1. Open the form. 
2. If necessary, use the Search function in the form to 

display the data table. 
3. In the View menu, select Saved to view the previously 

saved custom view or Default to view the default view. 

 

How do I create a custom view of a table 
within a form? 
1. Open the form. 
2. If necessary, use the Search function in the form to 

display the data table. 
3. In the View menu, select Custom. 
4. In the Customize toolbar, select the option(s) to change 

the table display, as described in the table to the right. 
5. If you want to save the result, click the Save button. 
If you don’t save it, the changes are lost when you close the 
form window. 

L Warning: The tables in form windows 
have a fixed width. 

You cannot add a field column that does not fit within 
this fixed width. If you try you get an error message. 
In such cases, remove a field, or adjust the width of 
existing fields to accommodate the column. 

 

 

Multi-view Table Customization Toolbar 

 
 

Button Function 

   
Scrolls visible fields during edit mode. 

   
Narrow/widen selected field by one 
character. 

   
Shifts the selected field left/right. 

 
Deletes the selected field from the table (you 
can add it back in with the button below). 

 
Opens the Customize window in which you 
can select/deselect available fields. 

 
Opens the Change Header window. Either: 

 Type a new header name. Click OK. 

 Click Default to reset the header name. 

 
Opens the Search window to search for data 
values within the selected field: 

 For a text field: type the text, select 
Match case, Search from first row if 
desired, click Search. 

 For a numerical field: type the min/max 
values, select Search from first row if 
desired, click Search. 

Each click on Search displays the next 
matching record, if there is one. When there 
are no more matches, a message is displayed: 
The Search found no match. 

 
Saves the changes in the “Saved View” for 
future use.  
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Entering Data 4 
  

The Date Entry Calendar 

Date fields have an associated calendar  button. 

 

1. To open the calendar window, click . 

Data Entry Methods 
Data values may be entered in a variety of ways: 

 Text values typed directly into text fields. 

 Text values selected from drop-down lists. 

 Text values selected from List of Value (LOV) window. 

 Dates selected from pop-up calendars. 

You should be very familiar with the first two options. 
The controls for the last two options are described on this page. 

 

The List of Values (LOV) window 
Certain text fields have an associated LOV  button, initial 

search field and sometimes a Comments  button. 

 

 

2. Use   and the month and 
year drop-down lists to select the 
monthly calendar. 

3. To populate the date field, click 
the desired date. 

 The calendar will not display 
illegal dates (e.g., a PO creation 
date before the current date). 

 
 

1. If you know the exact 
value, you can type it 
directly in the text entry 
field. 

2. To search for a value 
before opening the LOV, 
type search text in the 
Initial Search field. 

 

 3. Click  to open the LOV window. For certain fields with lots 
of records, e.g., Item Description, this can take some time. 

4. Once the LOV window is open, in its Find field, type search 
text to narrow the values displayed in the list. (The Find field 
is automatically selected for your input.) 

 Clicking  opens a small text editor for more extensive text 
entry.  

5. In the list, select a value. It will then populate the text entry 
field. 

 

Form Buttons 
The following buttons are commonly found on forms. 

Button Function 

 
Adds a blank record for data entry. 

 
Redisplays a search form with previous 
entry intact for further editing (not all 
search forms have this option). 

 
Closes the form without accepting 
changes. 

 
Closes the form and accepts and saves 
all changes. 

 
Deletes the currently selected record. 

 
Closes the form and accepts and saves 
all changes. 

 
Accepts and saves all changes and 
clears the form for adding a new 
record or editing an existing record. 

 
Clears the form fields for entry. 

 

Date Entry window 
Text entry field Initial search field 

LOV window 
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4 Entering Data … continued 

The Form Tool Bar: Every form shares the same standard tool bar at the top. 

      
Opens a 
new Retek 
Enterprise 
Start 
window. 

Opens an Internet address 
field: Type a valid URL and 
click Go to open the Web 
page in a separate browser 
window. 

Activates translation of the 
current field into any of the 
supported languages (Not 
currently active). 

Opens a window 
from which you may 
select a report. (Not 
currently active) 

Prints a 
screen shot 
of the active 
window. 

Opens the 
Online Help 
file for the 
active 
window. 

 

5 Using Search Forms to Find Information 

 

Search Forms 
Many forms first open as a search window. You enter or select 
the search criteria, click Search and the form changes to a table 
displaying the search results. 
Some forms combine a search section and a results section. 
Search criteria fields employ text fields, drop-down lists, LOV 
fields and date entry calendars. 
All search criteria is additive: only results that match all the 
criteria are displayed. 

How do I use a search form? 
1. Open the form. 
2. From the Action drop down list, select an action. One or 

more search criteria fields become available. 
3. Enter or select the appropriate search criteria. 
4. Click Search. In some cases the form changes to a results 

table. 
5. In the results table, select the desired record. 
6. Either: 

 Click OK to display the record. 

 Click Back to return to the search form keeping the 
same criteria (not all search forms have this option). 

 Click Refresh to return to the search form with all 
criteria fields cleared. 

 

Search form 

 
Results form  
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Using Online Help 6 

How do I access RMS Online Help? 
There are two ways to access the online help system: 

1. From the Help menu, select an option. 

Option Result 
Contents Opens to the Welcome page. 

Window 
Level 

Opens to the page that describes the 
currently active form window. 

Display Error Certain serious errors display a 
distinctive error message. When these 
errors occur, click this option and a 
window providing additional 
information will appear. Screen print 
this window to aid support personnel in 
diagnosing the error. 

Show keys Displays RMS keystroke shortcuts for 
the active window. 

 

2. Clicking  on the form Toolbar opens the help page 
describing the active form window. 

 

L Tip: The most efficient way to access 

form-specific help is by clicking  in the form Toolbar.  

RMS Online Help is similar to Windows Help 
The RMS Online Help always displays in a separate browser 
window. It is organized like Windows help into two vertical 
panes.  
The left pane has tabs for a table of contents, index and a search 
function. The right pane contains the help topic text. 
Long help topics have links near the beginning to the subtopics 
within the main topic, such as procedures and field 
descriptions. 

 
 

 

 

 

 

 

Left pane: 
 Contents 
 Index 
 Search 

Right pane: 
Help topic text 

RMS Online Help 
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7 Exiting RMS 

How do I exit the application? 
Closing the last open window closes the application. 
Some form windows close with a Close button, some with an 
OK button.  
You should either click the Close button or OK button 
in form windows.  
To close the Retek Enterprise Start window, from the 
Action menu, select Close. 
 

  

L Warning: To save current data entry  

in a form window, you must click the Close or 
OK button, as appropriate. Closing a form 
window by clicking Close in the application 
Action menu will not save the current data 
entry. 
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